Edy's Hub

プログラミング・シェアハウス・ライフスタイルについて書き綴っています

Rubyのバージョンを2.5.3に上げる〜Docker編〜

はじめに

Dockerfileを編集

rubyのバージョンを2.5.3に変更

$ docker-compose up --build

はいエラー bundlerのバージョンがよろしくないみたいですね。

docker-image

bundlerのバージョンを変更

-  gem 'bundler', '1.15.4'
+  gem 'bundler', '1.17.2'

Gemfile.lock内の古いバージョンの記述も変更します。 基本的にbundlerでgrepしてあげたら良いですが、最下部にある BUNDLED_WITH の変更も忘れないように。

 BUNDLED WITH
-   1.15.4
+   1.17.2

これでDockerのビルドが成功しました。